Oh, Dearest Mother, Sweetest Virgin of Altagracia, our Patroness. You are our Advocate and to you we recommend our needs. You are our Teacher and like disciples we come to learn from the example of your holy life. You are our Mother, and like children, we come to offer you all of the love of our hearts. Receive, dearest Mother, our offerings and listen attentively to our supplications. Amen.



Active Topics || Favorites || Member List || Search || About Us || Help || Register || Login
Technical Help!
 4Real Forums : Technical Help!
Subject Topic: subscript/superscript Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
stefoodie
Forum Moderator
Forum Moderator
Avatar

Joined: Feb 17 2005
Location: Ohio
Online Status: Offline
Posts: 8456
Posted: Nov 17 2011 at 11:09am | IP Logged Quote stefoodie

Hi Tim! just noticed that some of the links/words are showing up as superscript or subscript in some posts. thought i'd put a bug in your ear :)

__________________
stef

mom to five
... and these Thy gifts ...
The Homeschooler's Book Blog
Back to Top View stefoodie's Profile Search for other posts by stefoodie Visit stefoodie's Homepage
 
MaryM
Board Moderator
Board Moderator
Avatar

Joined: Feb 11 2005
Location: Colorado
Online Status: Offline
Posts: 13104
Posted: Nov 17 2011 at 12:32pm | IP Logged Quote MaryM


Where are you seeing this, stef? I haven't noticed anything in any threads I've read, but I'm wondering if it is browser specific with the changes in code that Tim is working on.   

Anyone else seeing it?

__________________
Mary M. in Denver

Our Domestic Church
Back to Top View MaryM's Profile Search for other posts by MaryM Visit MaryM's Homepage
 
Mackfam
Board Moderator
Board Moderator
Avatar
Non Nobis

Joined: April 24 2006
Location: Alabama
Online Status: Offline
Posts: 14656
Posted: Nov 17 2011 at 12:39pm | IP Logged Quote Mackfam

Yes it happens to me too. I posted about it on a recent technical help thread. It's random.   

__________________
Jen Mackintosh
Wife to Rob, mom to dd 19, ds 16, ds 11, dd 8, and dd 3
Wildflowers and Marbles
Back to Top View Mackfam's Profile Search for other posts by Mackfam Visit Mackfam's Homepage
 
Betsy
Forum All-Star
Forum All-Star
Avatar

Joined: July 02 2006
Online Status: Offline
Posts: 1962
Posted: Nov 17 2011 at 12:43pm | IP Logged Quote Betsy

I think that spontaneous subscripting has existed for awhile (i.e. not caused by a recent update).   From what I can determine it's quite random and there is no know reason for it happening.

The issue was also brought up in this thread fairly recently.



__________________
ImmaculataDesigns.com
When handcrafting my work, I always pray that it will raise your heart to all that is true, modest, just, holy, lovely and good fame!
Back to Top View Betsy's Profile Search for other posts by Betsy
 
stefoodie
Forum Moderator
Forum Moderator
Avatar

Joined: Feb 17 2005
Location: Ohio
Online Status: Offline
Posts: 8456
Posted: Nov 17 2011 at 1:34pm | IP Logged Quote stefoodie

It's in this post. Notice Erin's "interested" and "shared"

__________________
stef

mom to five
... and these Thy gifts ...
The Homeschooler's Book Blog
Back to Top View stefoodie's Profile Search for other posts by stefoodie Visit stefoodie's Homepage
 
JodieLyn
Forum Moderator
Forum Moderator
Avatar

Joined: Sept 06 2006
Location: Oregon
Online Status: Offline
Posts: 12234
Posted: Nov 17 2011 at 2:33pm | IP Logged Quote JodieLyn

I don't see it Stef.

I wonder if it's something on the individual computers.. I know there are some apps that will highlight/link words in a post that are only on the individual computer.. maybe something like that?

__________________
Jodie, wife to Dave
G-18, B-17, G-15, G-14, B-13, B-11, G-9, B-7, B-5, B-4

All men who have turned out worth anything have had the chief hand in their own education.
-Sir Walter Scott
Back to Top View JodieLyn's Profile Search for other posts by JodieLyn
 
stefoodie
Forum Moderator
Forum Moderator
Avatar

Joined: Feb 17 2005
Location: Ohio
Online Status: Offline
Posts: 8456
Posted: Nov 17 2011 at 5:21pm | IP Logged Quote stefoodie

Hm. The "interested" is in superscript and the "shared" is subscript in both Chrome and Safari, but normal in Firefox. Must be a browser thing.

__________________
stef

mom to five
... and these Thy gifts ...
The Homeschooler's Book Blog
Back to Top View stefoodie's Profile Search for other posts by stefoodie Visit stefoodie's Homepage
 
MaryM
Board Moderator
Board Moderator
Avatar

Joined: Feb 11 2005
Location: Colorado
Online Status: Offline
Posts: 13104
Posted: Nov 25 2011 at 8:27pm | IP Logged Quote MaryM

Betsy wrote:
From what I can determine it's quite random and there is no know reason for it happening.


Turns out it is not random at all. It was nagging at me - I could see it on one computer/browser in our house but not the other. Then I noticed something else about it's proximity to emoticons and did some investigating and have found the "cause." Only a few people can see it since the code conditions have to be just right and it has to be on particular browsers.

...so, this is the deal...

Whether or not a member sees the superscript/subscript is dependent of the computer and browser. When I am using Safari on my old laptop I can't see any issues - everything is same level. But when I am looking on my daughter's new Mac with Google Chrome or newer version of Safari there are words that are pushed down into subscript. I noticed something when I could see that and experimented with it. I had noticed in the past that large/moving emoticons change line spacing in posts when they are big. And there were emoticons in the line where ever this subscript was happening so I wondered if it were emoticon driven.

So where ever there is an emoticon on the same line as brackets for code [ ] (where ever there are links, italics, bold, underlining, etc.) then you will get the sub/superscript appearance (in some browsers) of whatever is IN THE BRACKETS on that line only. If you remove the emoticon - the line of text is fine.

See examples:

I am very interested to see how this works. & a link

I am very interested to see how this works. & a link

Some of you will not see any difference between the two lines (besides the emoticon missing), but for some with the specific browser changing issues, the two lines will be different and appear with the sub/superscript of anything that is coded for italics, bold, link.

Again it only happens when they (emoticons) are on the same line with bracket codes.

Blame it on the emoticons......(oh, and particular browsers).

Now, whether or not there is a fix for this - we'll see what Tim says. It doesn't affect very many folks. It would help if you are able to see it, to let us know which browser (and version) and computer type you have.
Back to Top View MaryM's Profile Search for other posts by MaryM Visit MaryM's Homepage
 
administrator
Forum Admin
Forum Admin
Avatar

Joined: Oct 01 2003
Online Status: Offline
Posts: 161
Posted: Nov 26 2011 at 1:50pm | IP Logged Quote administrator

Mary-

Can you create a screenshot of the behavior as it appears in your post above and email it to me? I suspect that this is a bug in Chrome (maybe only in Chrome for the Mac), and I am curious to compare what you are seeing with the actual HTML.

thanks-
Tim
Back to Top View administrator's Profile Search for other posts by administrator
 
Mackfam
Board Moderator
Board Moderator
Avatar
Non Nobis

Joined: April 24 2006
Location: Alabama
Online Status: Offline
Posts: 14656
Posted: Nov 26 2011 at 2:33pm | IP Logged Quote Mackfam

I'm posting some screenshots since I see the subscripts. Hopefully Mary can do the same.

Using a mac, running OS 10.6.8.

Safari 5.1.1


Chrome 15.0.874.121


Firefox 8.0.1 NO SUBSCRIPTS IN FIREFOX FOR ME


__________________
Jen Mackintosh
Wife to Rob, mom to dd 19, ds 16, ds 11, dd 8, and dd 3
Wildflowers and Marbles
Back to Top View Mackfam's Profile Search for other posts by Mackfam Visit Mackfam's Homepage
 
theNetSmith
Forum Admin
Forum Admin
Avatar

Joined: Jan 20 2005
Location: Texas
Online Status: Offline
Posts: 838
Posted: Nov 28 2011 at 8:24pm | IP Logged Quote theNetSmith

Thanks, Jen. Screenshots go a LONG way with tech support personnel!

After seeing the behavior first-hand -- especially the commonality between Safari and Chrome -- I started investigating the probability that this was a CSS standards issue. Fortunately, Chrome for Windows renders the page just like Chrome for the Mac, so I was able to reproduce the behavior and find a solution shortly after downloading/installing it.

I have modified the code that stores posts in the database so that image tags are created with an explicit alignment value. This will fix the problem going forward but does not correct it for posts already in the database. Existing posts can be 'corrected' by clicking 'Edit' and then resubmitting with no changes to the content (as I did with Mary's post above).

If you come across a post where this behavior is occurring, let one of the mods (or myself) know about it and we can take care of putting it right!

thanks-
Tim

__________________
There are many different ways of bringing people into his Kingdom; I have therefore learned to be cautious in my judgment.
-C.S. Lewis

Pray and forgive.
-Mother Theresa
Back to Top View theNetSmith's Profile Search for other posts by theNetSmith Visit theNetSmith's Homepage
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  [Add this topic to My Favorites] Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Hosting and Support provided by theNetSmith.com